Pix

Uit LinuxMintNL WiKi
Ga naar: navigatie, zoeken
Werk in uitvoering, help mee om het uit te breiden'
Pix
PixHoofdZijbalk.png
Informatie
Type Afbeeldingen verwerken
Officiële site Github Pix
Pix > Hulp > Inhoud
Licentie (GPLv2)
Instal via SoftwareBeheer
Locatie Menu >
Grafisch > Pix

Pix is in Linux Mint 18.x het standaard programma om uitgebreid afbeeldingen te bekijken en verwerken.

Voor het eenvoudig bekijken en verplaatsen van afbeeldingen zijn Afbeeldingviewer (Eye of GnOme - Mint 17.x) en Afbeeldingbekijker (Xviewer - Mint 18.x) ook geschikt, maar hebben minder mogelijkheden.

Hoofdprogramma

Het programma is een raamwerk waarin door middel van Extensies de gewenste handelingen kunnen worden verricht.

Er zijn bij installatie een kleine dertig extensies. Deze kunnen worden uitgebreid via Github, wat het niet voor iedereen eenvoudig maakt.

Enkele onderdelen zijn: bestanden zoeken, dia voorstelling, afbeelding catalogus, web album maken, camera import (gPhoto2), cd branden, werken met script, snel afbeeldingen bekijken (Xviewer), converteren, kleuren manipuleren en nog veel meer. [1]

De gebruikte schijfruimte is ±2MB.

Indeling

De indeling van de tab-menubalk is als volgt.

Bestand

Hierin zitten drie bijzondere opties waarvan hieronder extra informatie volgt.

Map maken

  • ?

Importeren

Na selectie van een Bron en instellen van Tonen zullen alle bestanden in die locatie die voldoen aan de instelling van "Tonen" worden weergegeven.

Er zijn twee locatie opties:

Verwijderbare media
Tonen van:
Hiermee word gezocht naar gekoppelde externe apparaten en wordt bij Bron aangegeven.
Hierbij is:
  • Bron
De importlocatie is de partitie waarin alle gewenste bestanden worden gezocht.
  • Tonen
Hier kan het soort bestand worden ingesteld waarnaar moet worden gezocht.
  • Doelmap
De map waarin de geselecteerde bestanden worden geplaatst en kan worden aangepast door dubbel klikken op de aangegeven locatie.
Ook sub-mappen kunnen dan worden ingesteld met een kruisje, waarbij de datum van het / de bestand(en) de map-namen vormt.
  • Gebeurtenis
Een mogelijkheid om een omschrijving van een gebeurtenis voor de verzameling te vermelden en wordt vermeld in de informatie van PIX bestanden.
  • Markering
Is een standaardnaam die aan mappen kan worden verbondenen en daarmee het zoeken te vereenvoudigen.
  • Verwijder geïmporteerde bestanden.
Pas op want de bestanden worden hiermee uit de bronlocatie verwijderd.
Map
Hiermee kan elke map in de home map van het hoofdsysteem worden geselecteerd.
Ook kunnen hiermee externe partities worden ge- ontkoppeld.

Exporteren

  • ?

Bewerken

Hier zijn twee opties met hieronder extra uitleg. De rest mag duidelijk zijn.

Zoek dubbele bestanden

Zoek dubbele bestanden

Hiermee opent een venster waar de te onderzoeken locatie (map) kan worden geselecteerd.

Door bij "Beginnen bij:" op de locatieregel te klikken kan een locatie worden ingesteld.

Tip: Als de Zijbalk is ingesteld, kan ook daar de locatie worden geselecteerd.

Onderin deze locatielijst kan met de optie "Andere..." iedere map voor onderzoek worden geselecteerd.

Filter

Met een kruisje bij "Inclusief submappen" wordt ook in de onderliggende mappen gezocht, anders wordt alleen de hoofdmap doorzocht. Met Filter wordt ingesteld naar welk soort bestanden wordt gezocht.

Na een klik op Zoeken kan het enige tijd duren voor alles is onderzocht. Met een voortgangsbalk kunnen de vorderingen worden gevolgd. Gevonden dubbele bestanden worden wel direct getoond.

Let op: Mappen die niet van de gebruiker zijn (root) kunnen worden geweigerd waarna de zoektocht wordt afgebroken. Met sudo pix in de terminal kan dit worden voorkomen.

Kiezen
Welke wilt U wissen?
Hier kan direct worden gekozen om bepaalde bestanden in een keer te selecteren.
  • Nieuwste ongemoeid laten
Hiermee worden alle dubbele bestanden geselecteerd, behalve de nieuwste.
  • Oudste ongemoeid laten
Hiermee worden alle dubbele bestanden geselecteerd, behalve de oudste.
  • Op map
Dit opent een selectielijst met mappen waarin dubbele bestanden zitten.
  • Alle bestanden (standaard)
Let op: Alle bestanden zijn aangekruist en alle bestanden worden hiermee gewist.
  • Geen bestanden.
Hiermee worden alle selecties opgeheven en kan niets worden gewist.
Zolang er wordt gezocht, worden alle nieuw gevonden dubbelen bestanden met een kruisje aangegeven.
Als op een bestand in het voorbeeldvenster wordt geklikt, worden in het onderste venster alle exemplaren van dat bestand met locatie getoond. Hiermee kunnen individuele bestanden eenvoudig worden onderzocht.
Beeld
Hiermee worden in het hoofdvenster van Pix alle geselecteerde dubbelbestanden getoond.
Hiervoor wordt in Pix de Afbeeldingbekijker gebruikt en kan daardoor alle bestandsinfo worden bekeken.
Voorbeeld
  • Wordt één bestand geselecteerd, dan worden alleen de dubbels van dat bestand in het hoofdvenster van Pix getoond.
  • Worden vijf bestanden geselecteerd, dan worden alle dubbels van die vijf bestanden in het hoofdvenster van Pix getoond.
  • Worden alle bestanden geselecteerd, dan worden alle dubbele bestanden in het hoofdvenster van Pix getoond.
Verwijderen
Als de selectie is voltooid kan op Verwijderen worden geklikt waarna alle bestanden met een kruisje worden verwijderd.

Voorkeuren

Beeld

Pix Beeld menu

Het Beeld-menu heeft de volgende opties:

Beëindigen en Herladen.

Deze opties zij wel duidelijk.

Werkbalk

Hiermee wordt een tweede werkbalk met snelwerk knoppen zichtbaar.

Statusbalk

De Statusbalk is de onderste balk van een venster en toont enige informatie over het bestand.

Zijbalk

Een venster aan de linker kant van het hoofdvenster met mappenoverzicht van de persoonlijk map en aangekoppelde externe mappen.

Filterbalk

Een extra balk boven de statusbalk met opties om alle bestanden te tonen of deze te filteren naar onderwerp.

Bekijk eigenschappen

Dit toont uitgebreide informatie over een geselecteerd bestand en wordt alleen zichtbaar als Zijbalk "Aan" staat.
De plaats van dit venster is afhankelijk van de instellingen in Voorkeuren in het Bewerken-menu.

Schermvullend & Diavoorstelling

Dit mag duidelijk zijn. Het kan ongedaan worden gemaakt met de ESC toets en herstart met de toetscombinatie CTRL+R.

Verbogen bestanden

Hiermee worden ook de verborgen bestanden getoond die voldoen aan de instellingen.

Filter
Sorteren

Opent een venster met sorteermogelijkheden.

Filter

De mogelijkheid om bestanden te filteren op bepaalde eigenschappen.

Miniaturen

Hiermee wordt de afbeelding getoond, of het icoon van de afbeelding-extensie.

Ga naar

Een menu met veel soorten locaties die hier kunnen worden geopend.

Bladwijzer menu

Bladwijzer

Hiermee kunnen bladwijzers worden aangemaakt en bewerkt. Een bladwijzer is een eenvoudige manier om een locatie te selecteren en te openen.

Het bladwijzer-venster kan in het Beeld-menu met Filterbalk worden geopend en verschijnt dan in de linker kantlijn met een mappenoverzicht. Hiermee kan direct een locatie worden geopend waarmee ook direct de afbeeldingen worden getoond.

Er zijn twee bijzondere locaties:

Catalogi

De Catalogi wordt samengesteld door met het muismenu van een bestand in Pix de optie "Toevoegen aan catalogus" te openen.

Hierdoor verschijnt een lijst met bestaande catalogi en een optie Overige.
Met Overige kan een nieuwe Catalogus of een nieuwe Bibliotheek worden aangemaakt.

Selecties

Met deze sterren selectie kan een waardering aan bepaalde onderdelen worden toegekend. Deze kenmerken kunnen weer worden gebruikt om snel bepaalde selecties te doorzoeken.

Een Selectie wordt toegevoegd door in het muismenu van een bestand in Pix de optie "Toevoegen aan selectie" aan te klikken en een ster te selecteren.

Hulp

De hulp is in het Engels.

Er is een Sneltoetslijst

Er is informatie over Pix en het versienummer.

Afbeelding bewerken

Afbeelding bewerk venster

In het bewerk-venster is mogelijk om een afbeelding in Pix te bewerken of een video te bekijken.

Open het bewerken-venster door dubbelklikken op een afbeelding of video.

Een video zal in dit venster worden afgespeeld.
Een afbeelding kan hiermee worden bewerkt.

Na het bewerken van een afbeelding deze nog wel even opslaan voordat wordt teruggegaan naar het hoofdvenster.

Sluit het berwerk-venster door op de ESC-toets te drukken.

Zie ook

Alle afbeelding programma's

Bronnen en referenties

  1. Github Pix inhoud